Apache 2.4 이상 버전에서 403 에러를 만났고,

error.log 를 보니 다음과 같은 에러가 있다면,


[Tue Dec 11 17:49:19.350384 2012] [authz_core:error] [pid 5308:tid 1576] [client 127.0.0.1:53603] AH01630: client denied by server configuration: /DOCUMENT_ROOT


mod_authz_core 에러일 가능성이 높다.


이럴 경우 <Directory> 접근 제한을 해제해야 하는데, 이전 버전과 다르다.


이전 버전은

<Directory /DOCUMENT_ROOT>

   ~~~

    Order allow,deny

    Allow from all

</Directory>


이런 식이었는데, 


아래처럼 바뀌었다.

<Directory /DOCUMENT_ROOT>

    ~~~

    Require all granted

</Directory>



아오 빡쳐...



참조: http://httpd.apache.org/docs/2.4/upgrading.html


Posted by bloodguy

댓글을 달아 주세요

  1. 지나가던 2016.03.19 18:40  댓글주소  수정/삭제  댓글쓰기

    감사합니다 ㅜㅜ

    이 문제때문에 엄청 고생했네요 ㅜㅜㅜㅜ

  2. doodoori2 2016.08.30 22:49  댓글주소  수정/삭제  댓글쓰기

    으아아아 그런거였군요